Home » Word Press

Install health check plugin to see if you are ready for WordPress 3.2

24 July 2010 No Comment

In a recent announcement team has announced that version 3.2 of will not support PHP 4 and MySQL 4. 3.1, which is due in late 2010, will be the last version of to support PHP 4.

WordPress 3.2, due in the first half of 2011, the minimum required PHP version will be raised to 5.2. The new required MySQL version for WordPress 3.2 will be 5.0.15.

Since the vast majority of WordPress users are using PHP 5.2 and it offers substantial improvements over earlier PHP 5 releases. It is also the minimum PHP version that the Drupal and Joomla projects will be supporting in their next versions, both due out this year.

WordPress users will not be able to upgrade to WordPress 3.2 if their hosting environment does not meet these requirements. The built-in updater will prevent the upgrade process in case it find PHP or MySQL to be below the required version.

To determine which versions your host provides WordPress team has created the Health Check plugin. Right now, Health Check will only tell you if you’re ready for WordPress 3.2. In a future release it will provide all sorts of useful information about your server and your WordPress install, so hang on to it!

In summary: WordPress 3.1, due in late 2010, will be the last version of WordPress to support PHP 4 and MySQL 4. WordPress 3.2, due in the first half of 2011, will require PHP 5.2 or higher, and MySQL 5.0.15 or higher. Install the Health Check plugin to see if you’re ready!

Leave your response!

Add your comment below, or trackback from your own site. You can also subscribe to these comments via RSS.

Be nice. Keep it clean. Stay on topic. No spam.

You can use these tags:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

This is a Gravatar-enabled weblog. To get your own globally-recognized-avatar, please register at Gravatar.